Gas cooktop failing to ignite after initial lighting

No longer serviced by Dometic but retained for reference and still open to members
artzend
Getting the hang of it
Posts: 10
Joined: Thu Aug 11, 2016 8:43 am

Re: Gas cooktop failing to ignite after initial lighting

Post by artzend » Sat Oct 29, 2016 7:37 am

Hi guys, finally back from sunny Queensland to the ice and snow of Vic. Back to my stove top.

I have tried the thermostat on one of the burners that does work, and it seems to be fine, but the non lighting burner, still doesn't light. I tried swapping the magnet bizzo too, still nothing on the original problem. I am not sure where to go from here, apart from taking it to a caravan place.

Any ideas?

Tim

User avatar
Old Techo
Over 10 kay Club
Posts: 11433
Joined: Fri Dec 26, 2008 1:23 pm
Location: Melbourne

Re: Gas cooktop failing to ignite after initial lighting

Post by Old Techo » Sat Oct 29, 2016 7:56 am

Tim, I think we need a recap here.

Now you are saying the dud burner does not light. Originally you said it did light but would not stay alight. What please is the present situation?

If still the latter issue, can you confirm that you removed the thermostat and the safety magnet from a known good burner and when both were fitted to the dud burner it lit OK but still would not remain alight?
Regards, Old Techo
2007 Prado Grande Diesel Auto
2004 Roadstar Limited Edition

artzend
Getting the hang of it
Posts: 10
Joined: Thu Aug 11, 2016 8:43 am

Re: Gas cooktop failing to ignite after initial lighting

Post by artzend » Sat Oct 29, 2016 12:09 pm

Yes, correct, I have swapped both pieces with other burners and they work ok. I can still light the burner but it doesn't carry on when I let the pressure off.

T

Post Reply

Return to “Dometic”